Skip to content
GitLab
Menu
Projects
Groups
Snippets
Help
Projects
Groups
Snippets
Loading...
Help
Help
Support
Community forum
Keyboard shortcuts
?
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
Menu
Open sidebar
wanghuo-open
meta-openembedded
Commits
c5e512ae
Commit
c5e512ae
authored
14 years ago
by
Martin Jansa
Committed by
Koen Kooi
14 years ago
Browse files
Options
Download
Email Patches
Plain Diff
python-efl: import from meta-shr
Signed-off-by:
Martin Jansa
<
Martin.Jansa@gmail.com
>
parent
b6aa2bfb
master
daisy
daisy-next
danny
danny-next
denzil
denzil-next
dizzy
dizzy-next
dora
dora-next
dunfell
dunfell-next
dylan
dylan-next
fido
fido-next
gatesgarth
gatesgarth-next
hardknott
hardknott-next
honister
honister-next
jansa/master
jethro
jethro-next
kirkstone
kirkstone-next
kraj/dunfell
krogoth
krogoth-next
langdale
langdale-next
master-next
morty
morty-next
pyro
pyro-next
rocko
rocko-next
stable/dufell-nut
stable/thud-next
stable/thud-nmut
sumo
sumo-next
thud
thud-next
warrior
warrior-next
zeus
zeus-next
No related merge requests found
Changes
8
Hide whitespace changes
Inline
Side-by-side
Showing
8 changed files
meta-efl/recipes-devtools/python/python-ecore_svn.bb
+6
-0
meta-efl/recipes-devtools/python/python-ecore_svn.bb
meta-efl/recipes-devtools/python/python-edbus_svn.bb
+7
-0
meta-efl/recipes-devtools/python/python-edbus_svn.bb
meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch
+38
-0
...ools/python/python-edje/0001-fix-unicode-conversion.patch
meta-efl/recipes-devtools/python/python-edje_svn.bb
+8
-0
meta-efl/recipes-devtools/python/python-edje_svn.bb
meta-efl/recipes-devtools/python/python-efl.inc
+46
-0
meta-efl/recipes-devtools/python/python-efl.inc
meta-efl/recipes-devtools/python/python-elementary_svn.bb
+6
-0
meta-efl/recipes-devtools/python/python-elementary_svn.bb
meta-efl/recipes-devtools/python/python-emotion_svn.bb
+6
-0
meta-efl/recipes-devtools/python/python-emotion_svn.bb
meta-efl/recipes-devtools/python/python-evas_svn.bb
+5
-0
meta-efl/recipes-devtools/python/python-evas_svn.bb
with
122 additions
and
0 deletions
+122
-0
meta-efl/recipes-devtools/python/python-ecore_svn.bb
0 → 100644
View file @
c5e512ae
require python-efl.inc
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
SRCREV = "${EFL_SRCREV}"
DEPENDS += "python-evas ecore"
RDEPENDS_${PN} += "python-evas"
This diff is collapsed.
Click to expand it.
meta-efl/recipes-devtools/python/python-edbus_svn.bb
0 → 100644
View file @
c5e512ae
require python-efl.inc
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
SRCREV = "${EFL_SRCREV}"
DEPENDS += "edbus python-dbus"
RDEPENDS_${PN} += "python-dbus"
SRCNAME = "python-e_dbus"
This diff is collapsed.
Click to expand it.
meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch
0 → 100644
View file @
c5e512ae
From fa12a33b5a3c0e86231ca84967d9eff456e5f314 Mon Sep 17 00:00:00 2001
From: Jan Luebbe <jluebbe@debian.org>
Date: Sat, 9 Aug 2008 18:30:04 +0200
Subject: [PATCH] fix unicode conversion
---
edje/edje.c_edje_object.pxi | 11 +++++++----
1 files changed, 7 insertions(+), 4 deletions(-)
diff --git a/edje/edje.c_edje_object.pxi b/edje/edje.c_edje_object.pxi
index 0f4da68..21c237e 100644
--- a/edje/edje.c_edje_object.pxi
+++ b/edje/edje.c_edje_object.pxi
@@ -415,17 +415,20 @@
else:
raise TypeError("func must be callable or None")
- def part_text_set(self, char *part, char *text):
- edje_object_part_text_set(self.obj, part, text)
+ def part_text_set(self, char *part, text):
+ cdef char *s
+ u = text.encode("utf8")
+ s = u
+ edje_object_part_text_set(self.obj, part, s)
def part_text_get(self, char *part):
- "@rtype: str"
+ "@rtype: unicode"
cdef const_char_ptr s
s = edje_object_part_text_get(self.obj, part)
if s == NULL:
return None
else:
- return s
+ return s.decode("utf8")
def part_text_select_all(self, char *part):
edje_object_part_text_select_all(self.obj, part)
This diff is collapsed.
Click to expand it.
meta-efl/recipes-devtools/python/python-edje_svn.bb
0 → 100644
View file @
c5e512ae
require python-efl.inc
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
SRCREV = "${EFL_SRCREV}"
DEPENDS += "edje python-evas"
RDEPENDS_${PN} += "python-evas"
SRC_URI += "file://0001-fix-unicode-conversion.patch"
This diff is collapsed.
Click to expand it.
meta-efl/recipes-devtools/python/python-efl.inc
0 → 100644
View file @
c5e512ae
DESCRIPTION
=
"${PN} bindings"
LICENSE
=
"BSD"
AUTHOR
=
"Gustavo Sverzut Barbieri <barbieri@gmail.com>"
# NOTE: Due to a bug in distutils, even if we don't use pyrex but cython,
# we need to build pyrex otherwise cython doesn't get called to build
# the extension modules.
DEPENDS
=
"python-cython-native python-pyrex-native python-numeric eina"
RDEPENDS_
$
{
PN
}
+=
"python-lang"
PV
=
"0.7.3+svnr${SRCPV}"
PR
=
"ml1"
# necessary to let the call for python-config succeed
export
BUILD_SYS
export
HOST_SYS
inherit
e
-
base
autotools
pkgconfig
distutils
-
base
SRC_URI
=
"${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};proto=http"
S
=
"${WORKDIR}/${SRCNAME}"
do_configure_prepend
()
{
# prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
sed
-
i
"s#\`
\$
PKG_CONFIG --variable=includedir
\"
python-evas#${STAGING_DIR_HOST}\`
\$
PKG_CONFIG --variable=includedir
\"
python-evas#g"
$
{
S
}
/
configure
.
ac
}
do_install_append
()
{
if
[
-
e
examples
];
then
for
i
in
`find examples -name "*.edc"`
;
do
cd
$
{
S
}
/
`dirname $i`
echo
"Generating .edj file for
$i
..."
edje_cc
`basename $i`
echo
"Removing sources in this directory..."
rm
-
f
*.
edc
*.
png
*.
ttf
*.
jpeg
done
cd
$
{
S
}
install
-
d
$
{
D
}
$
{
datadir
}
/
$
{
PN
}
/
cp
-
a
examples
$
{
D
}
$
{
datadir
}
/
$
{
PN
}
/
find
$
{
D
}
$
{
datadir
}
/
$
{
PN
}
/
examples
-
name
".svn"
|
xargs
rm
-
rf
fi
}
FILES_
$
{
PN
}
-
dbg
+=
"${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug"
PACKAGES
+=
"${PN}-examples"
FILES_
$
{
PN
}
-
examples
=
"${datadir}/${PN}/examples"
This diff is collapsed.
Click to expand it.
meta-efl/recipes-devtools/python/python-elementary_svn.bb
0 → 100644
View file @
c5e512ae
require python-efl.inc
LICENSE = "LGPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6"
SRCREV = "${EFL_SRCREV}"
DEPENDS += "elementary python-evas"
RDEPENDS_${PN} += "python-evas python-ecore python-edje"
This diff is collapsed.
Click to expand it.
meta-efl/recipes-devtools/python/python-emotion_svn.bb
0 → 100644
View file @
c5e512ae
require python-efl.inc
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
SRCREV = "${EFL_SRCREV}"
DEPENDS += "emotion python-evas"
RDEPENDS_${PN} += "python-ecore"
This diff is collapsed.
Click to expand it.
meta-efl/recipes-devtools/python/python-evas_svn.bb
0 → 100644
View file @
c5e512ae
require python-efl.inc
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
SRCREV = "${EFL_SRCREV}"
DEPENDS += "evas"
This diff is collapsed.
Click to expand it.
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
.
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment
Menu
Projects
Groups
Snippets
Help