Commit e551f7b3 authored by Martin Jansa's avatar Martin Jansa
Browse files

qtwebkit: Fix build with gcc-13


* there are few newer commits since the SRCREV used in this recipe
  it might be useful if someone is still using this (I don't, so
  I'll just fix the build failure with gcc-13 and cleanup the .patch files):

$ git log --oneline 10cd6a106..origin/5.212
ac8ebc6c3 (origin/5.212) Enable QML tests
5a99e5d4c Import QtWebKit commit 5d89eef9bc689abb59ef799b445c35b1e322b3f1
685ed792f Import QtWebKit commit 143b469188bde226d5e70cff5f01699b8a29d865
8967b4f87 Import QtWebKit commit 6faf5d547055321f0d518fe83766499cac5d8664
08eaf858c Import QtWebKit commit cf37bc44f798d3c5a26d17086ada92688b9bfe6d
412e257d0 Workaround for Windows Store python3.exe
e16357a52 Import QtWebKit commit f966d667c14ddcfe983f4a31fc80a1edbb6ada10
Signed-off-by: default avatarMartin Jansa <Martin.Jansa@gmail.com>
parent 3b21fad6
Showing with 87 additions and 45 deletions
+87 -45
From 34018c2a61045c58f88e09a12ecd62533aa2c2f1 Mon Sep 17 00:00:00 2001
From 34100abf0a24b3d2dadebe90926eea98d50a43b8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Mon, 4 Jun 2018 10:35:46 +0200
Subject: [PATCH] Do not skip build for cross-compile
......
From c4ceb318aa1064bfa677cdd800c52155eb1bed3a Mon Sep 17 00:00:00 2001
From a454e27d7993de8a3aa7e5cc37d7e16803da4271 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 23 Aug 2018 04:06:17 +0000
Subject: [PATCH] Fix build with non-glibc libc on musl
......
From f6576377f8bf2c854d8079b7f309f570b3d2bde4 Mon Sep 17 00:00:00 2001
From fb5f7d19a390c399c35f9fbaa1185e309394666d Mon Sep 17 00:00:00 2001
From: Lei Maohui <leimaohui@cn.fujitsu.com>
Date: Fri, 31 Aug 2018 15:42:48 +0900
Subject: [PATCH] Fix build bug for armv32 BE.
......
From 83aa5b3265d7c9f64e754cb890988cf8a5669ce7 Mon Sep 17 00:00:00 2001
From 597d54c6553cd9ffbf08e40a7a706096b8990399 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Mon, 24 Sep 2018 02:11:10 -0700
Subject: [PATCH] PlatformQt.cmake: Do not generate hardcoded include paths
......@@ -15,10 +15,10 @@ Upstream-Status: Pending
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Source/WebKit/PlatformQt.cmake b/Source/WebKit/PlatformQt.cmake
index 9aed9906e..48638aef4 100644
index 65c1ff1c1..b7ef82f4e 100644
--- a/Source/WebKit/PlatformQt.cmake
+++ b/Source/WebKit/PlatformQt.cmake
@@ -512,7 +512,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS)
@@ -511,7 +511,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS)
install(FILES ${WebKit_PKGCONFIG_FILENAME} DESTINATION ${ECM_PKGCONFIG_INSTALL_DIR} COMPONENT Data)
endif ()
......@@ -27,7 +27,7 @@ index 9aed9906e..48638aef4 100644
set(WebKit_PRI_ARGUMENTS
BIN_INSTALL_DIR "$$QT_MODULE_BIN_BASE"
LIB_INSTALL_DIR "$$QT_MODULE_LIB_BASE"
@@ -737,7 +737,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS)
@@ -741,7 +741,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS)
install(FILES ${WebKitWidgets_PKGCONFIG_FILENAME} DESTINATION ${ECM_PKGCONFIG_INSTALL_DIR} COMPONENT Data)
endif ()
......
From d92b11fea65364fefa700249bd3340e0cd4c5b31 Mon Sep 17 00:00:00 2001
From b579ee43a3f832e9b3785ed4cb03284cbc142ef1 Mon Sep 17 00:00:00 2001
From: Dmitry Shachnev <mitya57@gmail.com>
Date: Tue, 4 Aug 2020 21:04:06 +0300
Subject: [PATCH] Let Bison generate the header directly, to fix build with
......@@ -21,10 +21,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 1 insertion(+), 20 deletions(-)
diff --git a/Source/WebCore/css/makegrammar.pl b/Source/WebCore/css/makegrammar.pl
index 5d63b08102eb..9435701c7061 100644
index 5d63b0810..9435701c7 100644
--- a/Source/WebCore/css/makegrammar.pl
+++ b/Source/WebCore/css/makegrammar.pl
@@ -73,25 +73,6 @@
@@ -73,25 +73,6 @@ if ($suffix eq ".y.in") {
}
my $fileBase = File::Spec->join($outputDir, $filename);
......
From 32eb0352d98fcf325b0a94a4f7e141d746938a4b Mon Sep 17 00:00:00 2001
From d012406bcde49de9cba89f42a79ecba40b70a0ff Mon Sep 17 00:00:00 2001
From: Konstantin Tokarev <annulen@yandex.ru>
Date: Sun, 3 May 2020 18:50:24 +0300
Subject: [PATCH] Disable code related to HTTP/2 when Qt is configured without SSL support
Subject: [PATCH] Disable code related to HTTP/2 when Qt is configured without
SSL support
For enabling HTTP/2 by default we check if Qt uses OpenSSL and its version
is 1.0.2 or higher via QSslSocket API. While it would be sufficient to
......@@ -29,6 +30,3 @@ index 1154d56a0..87e21ec3f 100644
#define USE_HTTP2 1
#endif
--
2.29.2
From df9f6a8c9d59996b52bfdc5ea6f780de517905e5 Mon Sep 17 00:00:00 2001
From d478fb2ffb158e84e8705fdff3b7b2994a5d46c7 Mon Sep 17 00:00:00 2001
From: Konstantin Tokarev <annulen@yandex.ru>
Date: Wed, 3 Jun 2020 15:01:42 +0300
Subject: [PATCH] Fix compilation with Python 3.9: avoid passing encoding to
......@@ -27,6 +27,3 @@ index c5dab429c..af3431275 100644
except:
print("Unexpected error parsing {0}: {1}".format(bytecodeJSONFile, sys.exc_info()))
--
2.29.2
From 0e94085f74b562bf8edf5418142323785a069454 Mon Sep 17 00:00:00 2001
From 934ff3e2768a4ef2f1b21ee883acb56cb8ae898b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Wed, 2 Dec 2020 22:34:54 +0100
Subject: [PATCH] Fix build with icu >= 68
......@@ -120,6 +120,3 @@ index 7aaac48c8..6ac693602 100644
namespace WebCore {
// UTF16ContextAware provider
--
2.26.2
From b5a58d2c001689b07591fdce8820773d57a74002 Mon Sep 17 00:00:00 2001
From 2d43706b5b607ba2fdc777ef69532a75447cccd8 Mon Sep 17 00:00:00 2001
From: Chenxi Mao <chenxi.mao2013@gmail.com>
Date: Fri, 3 Apr 2020 08:33:10 +0800
Subject: [PATCH 1/1] Riscv: Add support for riscv
Subject: [PATCH] Riscv: Add support for riscv
Upstream-Status: Pending
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
......@@ -13,7 +13,7 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
4 files changed, 14 insertions(+), 3 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 31a2ea1fd..516476729 100644
index 432ae6fce..eaf3a35df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -83,6 +83,8 @@ elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "s390")
......@@ -26,10 +26,10 @@ index 31a2ea1fd..516476729 100644
message(FATAL_ERROR "Unknown CPU '${LOWERCASE_CMAKE_SYSTEM_PROCESSOR}'")
endif ()
diff --git a/Source/JavaScriptCore/CMakeLists.txt b/Source/JavaScriptCore/CMakeLists.txt
index 937b3ed00..2fff29f9d 100644
index afd76ca1a..3d184090d 100644
--- a/Source/JavaScriptCore/CMakeLists.txt
+++ b/Source/JavaScriptCore/CMakeLists.txt
@@ -1286,6 +1286,7 @@ elseif (WTF_CPU_S390)
@@ -1287,6 +1287,7 @@ elseif (WTF_CPU_S390)
elseif (WTF_CPU_S390X)
elseif (WTF_CPU_MIPS)
elseif (WTF_CPU_SH4)
......@@ -80,6 +80,3 @@ index 05302e6e6..25dd352ee 100644
#define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
#elif defined(_M_IX86) || defined(__i386__)
#if defined(_WIN32)
--
2.17.1
fix build on mips
From 7e3e0ca548cc9c92705308dd2e0f88ada544e794 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 26 Oct 2021 11:03:25 -0700
Subject: [PATCH] Fix build on mips
Fixes
Source/WTF/wtf/Atomics.cpp:63:9: error: definition of builtin function '__sync_add_and_fetch_8'
......@@ -7,8 +10,15 @@ Source/WTF/wtf/Atomics.cpp:68:9: error: definition of builtin function '__sync_s
int64_t __sync_sub_and_fetch_8(int64_t volatile* addend, int64_t value)
Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
Source/WTF/wtf/Platform.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/Source/WTF/wtf/Platform.h b/Source/WTF/wtf/Platform.h
index 8fac85f72..5b8bbcb18 100644
--- a/Source/WTF/wtf/Platform.h
+++ b/Source/WTF/wtf/Platform.h
@@ -88,6 +88,7 @@
......
From 330bdeeaa4389225c27d27188499543ddd184f69 Mon Sep 17 00:00:00 2001
From 3d3a5974ff31e55651bb0c47278bd15734d60be4 Mon Sep 17 00:00:00 2001
From: Adrian Perez de Castro <aperez@igalia.com>
Date: Wed, 15 Jan 2020 22:15:38 +0000
Subject: [PATCH] Offlineasm warnings with newer Ruby versions
https://bugs.webkit.org/show_bug.cgi?id=206233
https://bugs.webkit.org/show_bug.cgi?id=206233
Reviewed by Yusuke Suzuki.
......@@ -44,6 +45,3 @@ index b44511245..cd1cffaec 100644
elsif @tokens[@idx] == "\n"
# ignore
@idx += 1
--
2.39.0
From 8a82826054f55d17d9b765bc383418b750ed836b Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Wed, 12 Apr 2023 16:07:40 +0200
Subject: [PATCH] Fix build with gcc-13
* fixes:
http://errors.yoctoproject.org/Errors/Details/699653/
TOPDIR/tmp-glibc/work/core2-64-oe-linux/qtwebkit/5.15.9+gitAUTOINC+10cd6a106e-r0/git/Source/ThirdParty/ANGLE/src/common/mathutil.h:575:8: error: 'uint32_t' does not name a type
575 | inline uint32_t RotL(uint32_t x, int8_t r)
| ^~~~~~~~
TOPDIR/tmp-glibc/work/core2-64-oe-linux/qtwebkit/5.15.9+gitAUTOINC+10cd6a106e-r0/git/Source/ThirdParty/ANGLE/src/common/mathutil.h:19:1: note: 'uint32_t' is defined in header '<cstdint>'; did you forget to '#include <cstdint>'?
18 | #include <stdlib.h>
+++ |+#include <cstdint>
19 |
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Upstream-Status: Pending
---
Source/ThirdParty/ANGLE/src/common/mathutil.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/Source/ThirdParty/ANGLE/src/common/mathutil.h b/Source/ThirdParty/ANGLE/src/common/mathutil.h
index 7959da8bd..6a8e77b4d 100644
--- a/Source/ThirdParty/ANGLE/src/common/mathutil.h
+++ b/Source/ThirdParty/ANGLE/src/common/mathutil.h
@@ -12,6 +12,7 @@
#include "common/debug.h"
#include "common/platform.h"
+#include <cstdint>
#include <limits>
#include <algorithm>
#include <string.h>
link with libatomic
From 999affc771f761894b6fd6e491c6adac7861fcf2 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Mon, 8 Mar 2021 18:15:47 -0800
Subject: [PATCH] link with libatomic
This fixes build with C11
......@@ -6,8 +9,15 @@ lib/../Source/WTF/wtf/CMakeFiles/WTF.dir/Assertions.cpp.o:/usr/include/c++/11.0.
| collect2: error: ld returned 1 exit status
Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
Source/WTF/wtf/CMakeLists.txt | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/Source/WTF/wtf/CMakeLists.txt b/Source/WTF/wtf/CMakeLists.txt
index 297589b90..5b8d8c71b 100644
--- a/Source/WTF/wtf/CMakeLists.txt
+++ b/Source/WTF/wtf/CMakeLists.txt
@@ -245,6 +245,10 @@ if (NOT USE_SYSTEM_MALLOC)
......
......@@ -11,24 +11,25 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative icu ruby-native sqlite3 glib-2.0 libxslt gperf-native bison-native flex-native"
# Patches from https://github.com/meta-qt5/qtwebkit/commits/b5.13
# 5.13.meta-qt5.1
# Patches from https://github.com/meta-qt5/qtwebkit/commits/b5.212
# 5.212.meta-qt5.1
SRC_URI += "\
file://0001-Do-not-skip-build-for-cross-compile.patch \
file://0002-Fix-build-with-non-glibc-libc-on-musl.patch \
file://0003-Fix-build-bug-for-armv32-BE.patch \
file://0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \
file://0005-Fix-build-with-bison37.patch \
file://0005-Let-Bison-generate-the-header-directly-to-fix-build-.patch \
file://0006-Disable-code-related-to-HTTP-2-when-Qt-is-configured.patch \
file://0007-Fix-compilation-with-Python-3.9-avoid-passing-encodi.patch \
file://0008-Fix-build-with-icu-68.patch \
file://0009-Riscv-Add-support-for-riscv.patch \
file://mips-atomic.patch \
file://0001-Offlineasm-warnings-with-newer-Ruby-versions-https-b.patch \
file://0010-Fix-build-on-mips.patch \
file://0011-Offlineasm-warnings-with-newer-Ruby-versions.patch \
file://0012-Fix-build-with-gcc-13.patch \
"
SRC_URI:append:riscv32 = " file://0010-webdriver-libatomic.patch "
SRC_URI:append:riscv64 = " file://0010-webdriver-libatomic.patch "
SRC_URI:append:riscv32 = " file://0013-link-with-libatomic.patch"
SRC_URI:append:riscv64 = " file://0013-link-with-libatomic.patch"
inherit cmake_qt5 perlnative
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment