• Andreas Baak's avatar
    catkin: split up catkin in order to reduce runtime dependencies · 18588242
    Andreas Baak authored
    The catkin package has got a runtime dependency to cmake, make,
    gcc and other build utilities. These dependencies, however, are
    only needed if it is desired to build with catkin on the target
    board. If we do not want to build on the target board, i.e., if
    we just want to use ros tools like roslaunch, only a small part
    of catkin (i.e., the corresponding python packages) is required
    to be deployed on the target board.
    Therefore, we introduce a new package called catkin-runtime.
    It installs only the python packages that are required for
    the ros tools to run. The roslib package now depends on
    catkin-runtime (previously: catkin).
    
    I also tried an alternative approach which just modifies catkin.bb:
    - add a catkin-runtime package
    - move PYTHON_SITEPACKAGES_DIR from FILES_catkin to FILES_CATKIN_RUNTIME
    - make catkin_runtime RDEPEND on the python stuff
    - make catkin RDEPEND on the cmake, binutils, ..., + catkin-runtime
    With this setup, for some reason...
    18588242
catkin_0.5.90.bb 634 Bytes