• Martin Jansa's avatar
    {rolling} rmf-traffic-editor: add missing dependencies and restrict with qt5,... · e921b62b
    Martin Jansa authored
    
    {rolling} rmf-traffic-editor: add missing dependencies and restrict with qt5, qt5-widgets skip group
    
    * add ament-cmake-libraries to fix:
    | -- Found ament_cmake: 1.1.4 (/jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake)
    | CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmake_export_dependencies-extras.cmake:5 (find_package):
    |   By not providing "Findament_cmake_libraries.cmake" in CMAKE_MODULE_PATH
    |   this project has asked CMake to find a package configuration file provided
    |   by "ament_cmake_libraries", but CMake did not find one.
    |
    |   Could not find a package configuration file provided by
    |   "ament_cmake_libraries" with any of the following names:
    |
    |     ament_cmake_librariesConfig.cmake
    |     ament_cmake_libraries-config.cmake
    |
    |   Add the installation prefix of "ament_cmake_libraries" to CMAKE_PREFIX_PATH
    |   or set "ament_cmake_libraries_DIR" to a directory containing one of the
    |   above files.  If "ament_cmake_libraries" provides a separate development
    |   package or SDK, be sure it has been installed.
    | Call Stack (most recent call first):
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmakeConfig.cmake:41 (include)
    |   CMakeLists.txt:9 (find_package)
    
    * add ament-package-native to fix:
    -- Using PYTHON_EXECUTABLE: /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot-native/usr/bin/python3-native/python3
    Traceback (most recent call last):
      File "/jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake_core/cmake/package_templates/templates_2_cmake.py", line 21, in <module>
        from ament_package.templates import get_environment_hook_template_path
    ModuleNotFoundError: No module named 'ament_package'
    CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake_core/cmake/ament_cmake_package_templates-extras.cmake:41 (message):
    
      execute_process(/jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot-native/usr/bin/python3-native/python3
      /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake_core/cmake/package_templates/templates_2_cmake.py
      /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/build/ament_cmake_package_templates/templates.cmake)
      returned error code 1
    Call Stack (most recent call first):
      /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake_core/cmake/ament_cmake_coreConfig.cmake:41 (include)
      /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmake_export_dependencies-extras.cmake:15 (find_package)
      /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmakeConfig.cmake:41 (include)
      CMakeLists.txt:9 (find_package)
    
    * add ament-cmake-export-definitions to fix:
    | -- Using PYTHON_EXECUTABLE: /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot-native/usr/bi
    n/python3-native/python3
    | CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmak
    e/ament_cmake_export_dependencies-extras.cmake:21 (find_package):
    |   By not providing "Findament_cmake_export_definitions.cmake" in
    |   CMAKE_MODULE_PATH this project has asked CMake to find a package
    |   configuration file provided by "ament_cmake_export_definitions", but CMake
    |   did not find one.
    |
    |   Could not find a package configuration file provided by
    |   "ament_cmake_export_definitions" with any of the following names:
    |
    |     ament_cmake_export_definitionsConfig.cmake
    |     ament_cmake_export_definitions-config.cmake
    |
    |   Add the installation prefix of "ament_cmake_export_definitions" to
    |   CMAKE_PREFIX_PATH or set "ament_cmake_export_definitions_DIR" to a
    |   directory containing one of the above files.  If
    |   "ament_cmake_export_definitions" provides a separate development package or
    |   SDK, be sure it has been installed.
    | Call Stack (most recent call first):
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmakeConfig.cmake:41 (include)
    |   CMakeLists.txt:9 (find_package)
    
    * add ament-cmake-export-include-directories to fix:
    | -- Using PYTHON_EXECUTABLE: /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot-native/usr/bin/python3-native/python3
    | CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmake_export_dependencies-extras.cmake:21 (find_package):
    |   By not providing "Findament_cmake_export_include_directories.cmake" in
    |   CMAKE_MODULE_PATH this project has asked CMake to find a package
    |   configuration file provided by "ament_cmake_export_include_directories",
    |   but CMake did not find one.
    |
    |   Could not find a package configuration file provided by
    |   "ament_cmake_export_include_directories" with any of the following names:
    |
    |     ament_cmake_export_include_directoriesConfig.cmake
    |     ament_cmake_export_include_directories-config.cmake
    |
    |   Add the installation prefix of "ament_cmake_export_include_directories" to
    |   CMAKE_PREFIX_PATH or set "ament_cmake_export_include_directories_DIR" to a
    |   directory containing one of the above files.  If
    |   "ament_cmake_export_include_directories" provides a separate development
    |   package or SDK, be sure it has been installed.
    | Call Stack (most recent call first):
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmakeConfig.cmake:41 (include)
    |   CMakeLists.txt:9 (find_package)
    
    * add ament-cmake-export-interfaces to fix:
    | -- Using PYTHON_EXECUTABLE: /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot-native/usr/bin/python3-native/python3
    | CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmake_export_dependencies-extras.cmake:21 (find_package):
    |   By not providing "Findament_cmake_export_interfaces.cmake" in
    |   CMAKE_MODULE_PATH this project has asked CMake to find a package
    |   configuration file provided by "ament_cmake_export_interfaces", but CMake
    |   did not find one.
    |
    |   Could not find a package configuration file provided by
    |   "ament_cmake_export_interfaces" with any of the following names:
    |
    |     ament_cmake_export_interfacesConfig.cmake
    |     ament_cmake_export_interfaces-config.cmake
    |
    |   Add the installation prefix of "ament_cmake_export_interfaces" to
    |   CMAKE_PREFIX_PATH or set "ament_cmake_export_interfaces_DIR" to a directory
    |   containing one of the above files.  If "ament_cmake_export_interfaces"
    |   provides a separate development package or SDK, be sure it has been
    |   installed.
    | Call Stack (most recent call first):
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmakeConfig.cmake:41 (include)
    |   CMakeLists.txt:9 (find_package)
    |
    
    * add ament-cmake-export-libraries to fix:
    | -- Using PYTHON_EXECUTABLE: /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot-native/usr/bi
    n/python3-native/python3
    | CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmake_export_dependencies-extras.cmake:21 (find_package):
    |   By not providing "Findament_cmake_export_libraries.cmake" in
    |   CMAKE_MODULE_PATH this project has asked CMake to find a package
    |   configuration file provided by "ament_cmake_export_libraries", but CMake
    |   did not find one.
    |
    |   Could not find a package configuration file provided by
    |   "ament_cmake_export_libraries" with any of the following names:
    |
    |     ament_cmake_export_librariesConfig.cmake
    |     ament_cmake_export_libraries-config.cmake
    |
    |   Add the installation prefix of "ament_cmake_export_libraries" to
    |   CMAKE_PREFIX_PATH or set "ament_cmake_export_libraries_DIR" to a directory
    |   containing one of the above files.  If "ament_cmake_export_libraries"
    |   provides a separate development package or SDK, be sure it has been
    |   installed.
    | Call Stack (most recent call first):
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmakeConfig.cmake:41 (include)
    |   CMakeLists.txt:9 (find_package)
    
    * add ament-cmake-export-link-flags to fix:
    | CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmake_export_dependencies-extras.cmake:21 (find_package):
    |   By not providing "Findament_cmake_export_link_flags.cmake" in
    |   CMAKE_MODULE_PATH this project has asked CMake to find a package
    |   configuration file provided by "ament_cmake_export_link_flags", but CMake
    |   did not find one.
    |
    |   Could not find a package configuration file provided by
    |   "ament_cmake_export_link_flags" with any of the following names:
    |
    |     ament_cmake_export_link_flagsConfig.cmake
    |     ament_cmake_export_link_flags-config.cmake
    |
    |   Add the installation prefix of "ament_cmake_export_link_flags" to
    |   CMAKE_PREFIX_PATH or set "ament_cmake_export_link_flags_DIR" to a directory
    |   containing one of the above files.  If "ament_cmake_export_link_flags"
    |   provides a separate development package or SDK, be sure it has been
    |   installed.
    | Call Stack (most recent call first):
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmakeConfig.cmake:41 (include)
    |   CMakeLists.txt:9 (find_package)
    
    * add ament-cmake-export-targets to fix:
    | CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmake_export_dependencies-extras.cmake:21 (find_package):
    |   By not providing "Findament_cmake_export_targets.cmake" in
    |   CMAKE_MODULE_PATH this project has asked CMake to find a package
    |   configuration file provided by "ament_cmake_export_targets", but CMake did
    |   not find one.
    |
    |   Could not find a package configuration file provided by
    |   "ament_cmake_export_targets" with any of the following names:
    |
    |     ament_cmake_export_targetsConfig.cmake
    |     ament_cmake_export_targets-config.cmake
    |
    |   Add the installation prefix of "ament_cmake_export_targets" to
    |   CMAKE_PREFIX_PATH or set "ament_cmake_export_targets_DIR" to a directory
    |   containing one of the above files.  If "ament_cmake_export_targets"
    |   provides a separate development package or SDK, be sure it has been
    |   installed.
    | Call Stack (most recent call first):
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmakeConfig.cmake:41 (include)
    |   CMakeLists.txt:9 (find_package)
    
    * add ament-cmake-python to fix:
    | -- Using PYTHON_EXECUTABLE: /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot-native/usr/bin/python3-native/python3
    | CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmake_export_dependencies-extras.cmake:21 (find_package):
    |   By not providing "Findament_cmake_python.cmake" in CMAKE_MODULE_PATH this
    |   project has asked CMake to find a package configuration file provided by
    |   "ament_cmake_python", but CMake did not find one.
    |
    |   Could not find a package configuration file provided by
    |   "ament_cmake_python" with any of the following names:
    |
    |     ament_cmake_pythonConfig.cmake
    |     ament_cmake_python-config.cmake
    |
    |   Add the installation prefix of "ament_cmake_python" to CMAKE_PREFIX_PATH or
    |   set "ament_cmake_python_DIR" to a directory containing one of the above
    |   files.  If "ament_cmake_python" provides a separate development package or
    |   SDK, be sure it has been installed.
    | Call Stack (most recent call first):
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmakeConfig.cmake:41 (include)
    |   CMakeLists.txt:9 (find_package)
    
    * add ament-cmake-target-dependencies to fix:
    | -- Found PythonInterp: /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot-native/usr/bin/python3-native/python3 (found suitable version "3.9.4", minimum required is "3")
    | -- Using PYTHON_EXECUTABLE: /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot-native/usr/bin/python3-native/python3
    | CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmake_export_dependencies-extras.cmake:21 (find_package):
    |   By not providing "Findament_cmake_target_dependencies.cmake" in
    |   CMAKE_MODULE_PATH this project has asked CMake to find a package
    |   configuration file provided by "ament_cmake_target_dependencies", but CMake
    |   did not find one.
    |
    |   Could not find a package configuration file provided by
    |   "ament_cmake_target_dependencies" with any of the following names:
    |
    |     ament_cmake_target_dependenciesConfig.cmake
    |     ament_cmake_target_dependencies-config.cmake
    |
    |   Add the installation prefix of "ament_cmake_target_dependencies" to
    |   CMAKE_PREFIX_PATH or set "ament_cmake_target_dependencies_DIR" to a
    |   directory containing one of the above files.  If
    |   "ament_cmake_target_dependencies" provides a separate development package
    |   or SDK, be sure it has been installed.
    | Call Stack (most recent call first):
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmakeConfig.cmake:41 (include)
    |   CMakeLists.txt:9 (find_package)
    
    * add ament-cmake-include-directories to fix:
    | -- Using PYTHON_EXECUTABLE: /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot-native/usr/bin/python3-native/python3
    | CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake_target_dependencies/cmake/ament_cmake_target_dependencies-extras.cmake:19 (find_package):
    |   By not providing "Findament_cmake_include_directories.cmake" in
    |   CMAKE_MODULE_PATH this project has asked CMake to find a package
    |   configuration file provided by "ament_cmake_include_directories", but CMake
    |   did not find one.
    |
    |   Could not find a package configuration file provided by
    |   "ament_cmake_include_directories" with any of the following names:
    |
    |     ament_cmake_include_directoriesConfig.cmake
    |     ament_cmake_include_directories-config.cmake
    |
    |   Add the installation prefix of "ament_cmake_include_directories" to
    |   CMAKE_PREFIX_PATH or set "ament_cmake_include_directories_DIR" to a
    |   directory containing one of the above files.  If
    |   "ament_cmake_include_directories" provides a separate development package
    |   or SDK, be sure it has been installed.
    | Call Stack (most recent call first):
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake_target_dependencies/cmake/ament_cmake_target_dependenciesConfig.cmake:41 (include)
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmake_export_dependencies-extras.cmake:21 (find_package)
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmakeConfig.cmake:41 (include)
    |   CMakeLists.txt:9 (find_package)
    
    * add ament-cmake-test to fix:
    | -- Using PYTHON_EXECUTABLE: /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot-native/usr/bin/python3-native/python3
    | CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmake_export_dependencies-extras.cmake:21 (find_package):
    |   By not providing "Findament_cmake_test.cmake" in CMAKE_MODULE_PATH this
    |   project has asked CMake to find a package configuration file provided by
    |   "ament_cmake_test", but CMake did not find one.
    |
    |   Could not find a package configuration file provided by "ament_cmake_test"
    |   with any of the following names:
    |
    |     ament_cmake_testConfig.cmake
    |     ament_cmake_test-config.cmake
    |
    |   Add the installation prefix of "ament_cmake_test" to CMAKE_PREFIX_PATH or
    |   set "ament_cmake_test_DIR" to a directory containing one of the above
    |   files.  If "ament_cmake_test" provides a separate development package or
    |   SDK, be sure it has been installed.
    | Call Stack (most recent call first):
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmakeConfig.cmake:41 (include)
    |   CMakeLists.txt:9 (find_package)
    
    * add ament-cmake-version to fix:
    | -- Using PYTHON_EXECUTABLE: /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot-native/usr/bin/python3-native/python3
    | CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmake_export_dependencies-extras.cmake:21 (find_package):
    |   By not providing "Findament_cmake_version.cmake" in CMAKE_MODULE_PATH this
    |   project has asked CMake to find a package configuration file provided by
    |   "ament_cmake_version", but CMake did not find one.
    |
    |   Could not find a package configuration file provided by
    |   "ament_cmake_version" with any of the following names:
    |
    |     ament_cmake_versionConfig.cmake
    |     ament_cmake_version-config.cmake
    |
    |   Add the installation prefix of "ament_cmake_version" to CMAKE_PREFIX_PATH
    |   or set "ament_cmake_version_DIR" to a directory containing one of the above
    |   files.  If "ament_cmake_version" provides a separate development package or
    |   SDK, be sure it has been installed.
    | Call Stack (most recent call first):
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake/cmake/ament_cmakeConfig.cmake:41 (include)
    |   CMakeLists.txt:9 (find_package)
    
    * add python3-catkin-pkg-native and cmake_qt5 inherit to fix:
    | -- Found Ceres version: 2.0.0 installed in: /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr with components: [EigenSparse, SparseLinearAlgebraLibrary, LAPACK, SuiteSparse, CXSparse, SchurSpecializations, Multithreading]
    | CMake Warning at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/lib/cmake/Qt5/Qt5Config.cmake:7 (message):
    |   SkippingbecauseOE_QMAKE_PATH_EXTERNAL_HOST_BINSisnotdefined
    | Call Stack (most recent call first):
    |   CMakeLists.txt:13 (find_package)
    |
    |
    | Traceback (most recent call last):
    |   File "/jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake_core/cmake/core/package_xml_2_cmake.py", line 22, in <module>
    |     from catkin_pkg.package import evaluate_condition
    | ModuleNotFoundError: No module named 'catkin_pkg'
    | CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake_core/cmake/core/ament_package_xml.cmake:94 (message):
    |
    |   execute_process(/jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot-native/usr/bin/python3-native/python3
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake_core/cmake/core/package_xml_2_cmake.py
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/git/package.xml
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/build/ament_cmake_core/package.cmake)
    |   returned error code 1
    | Call Stack (most recent call first):
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake_core/cmake/core/ament_package_xml.cmake:49 (_ament_package_xml)
    |   /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/share/ament_cmake_core/cmake/core/ament_package.cmake:63 (ament_package_xml)
    |   CMakeLists.txt:156 (ament_package)
    
    * add qt5-widgets to fix:
    | CMake Error at /jenkins/mjansa/build/ros/webos-rolling-hardknott/tmp-glibc/work/qemux86-webos-linux/rmf-traffic-editor/1.3.0-3-r0/recipe-sysroot/usr/lib/cmake/Qt5/Qt5Config.cmake:33 (find_package):
    |   Could not find a package configuration file provided by "Qt5Widgets" with
    |   any of the following names:
    |
    |     Qt5WidgetsConfig.cmake
    |     qt5widgets-config.cmake
    |
    |   Add the installation prefix of "Qt5Widgets" to CMAKE_PREFIX_PATH or set
    |   "Qt5Widgets_DIR" to a directory containing one of the above files.  If
    |   "Qt5Widgets" provides a separate development package or SDK, be sure it has
    |   been installed.
    | Call Stack (most recent call first):
    |   CMakeLists.txt:13 (find_package)
    Signed-off-by: default avatarMartin Jansa <martin.jansa@lge.com>
    e921b62b
packagegroup-ros-world-rolling.bb 11.7 KB