Skip to content
GitLab
Menu
Projects
Groups
Snippets
Help
Projects
Groups
Snippets
Loading...
Help
Help
Support
Community forum
Keyboard shortcuts
?
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
Menu
Open sidebar
wanghuo-open
meta-ros
Commits
224b15a0
Commit
224b15a0
authored
10 years ago
by
KristofRobot
Browse files
Options
Download
Plain Diff
Merge pull request #319 from andreasbaak/master
Reduction of runtime dependencies
parents
47eab426
18588242
master
dunfell
dunfell-next
gatesgarth
gatesgarth-next
hardknott
hardknott-next
honister
honister-next
kirkstone
kirkstone-next
langdale
langdale-next
legacy
legacy-v2
master-next
master-previous
mickledore
mickledore-next
nanbield
nanbield-next
thud
thud-next
warrior
warrior-next
zeus
zeus-next
zeus/milestones/13
zeus/milestones/12
zeus/milestones/11
warrior/milestones/13
warrior/milestones/12
warrior/milestones/11
v0.2
v0.2rc3
v0.2rc2
v0.2rc1
thud/milestones/13
thud/milestones/12
thud/milestones/11
thud/milestones/10
thud/milestones/9
thud/milestones/8
thud/milestones/7
thud/milestones/6
thud/milestones/5
master/milestones/17
master/milestones/16
master/milestones/15
master/milestones/14
master/milestones/13
master/milestones/12
master/milestones/11
master/milestones/10
master/milestones/9
master/milestones/8
master/milestones/7
master/milestones/6
master/milestones/5
honister/milestones/17
hardknott/milestones/17
hardknott/milestones/16
gatesgarth/milestones/17
gatesgarth/milestones/16
gatesgarth/milestones/15
dunfell/milestones/17
dunfell/milestones/16
dunfell/milestones/15
dunfell/milestones/14
dunfell/milestones/13
dunfell/milestones/12
No related merge requests found
Changes
9
Hide whitespace changes
Inline
Side-by-side
Showing
9 changed files
classes/catkin.bbclass
+1
-1
classes/catkin.bbclass
recipes-ros/catkin/catkin-runtime_0.5.90.bb
+22
-0
recipes-ros/catkin/catkin-runtime_0.5.90.bb
recipes-ros/catkin/catkin.inc
+26
-0
recipes-ros/catkin/catkin.inc
recipes-ros/catkin/catkin_0.5.90.bb
+13
-25
recipes-ros/catkin/catkin_0.5.90.bb
recipes-ros/catkin/files/0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch
+0
-0
...s/0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch
recipes-ros/ros-comm/roslaunch_1.10.12.bb
+0
-1
recipes-ros/ros-comm/roslaunch_1.10.12.bb
recipes-ros/ros/rosclean/0001-rosclean-Use-du-sk-1024-on-Linux-for-getting-disk-us.patch
+35
-0
...osclean-Use-du-sk-1024-on-Linux-for-getting-disk-us.patch
recipes-ros/ros/rosclean_1.10.11.bb
+2
-0
recipes-ros/ros/rosclean_1.10.11.bb
recipes-ros/ros/roslib_1.10.11.bb
+1
-1
recipes-ros/ros/roslib_1.10.11.bb
with
100 additions
and
28 deletions
+100
-28
classes/catkin.bbclass
View file @
224b15a0
...
...
@@ -4,7 +4,7 @@
inherit cmake distutils-base ros faulty-solibs
DEPENDS_prepend = "${@['catkin-native ', ''][d.getVar('BPN', True) == 'catkin']}"
DEPENDS_prepend = "${@['catkin-native ', ''][
(
d.getVar('BPN', True) == 'catkin'
) | (d.getVar('BPN', True) == 'catkin-runtime')
]}"
EXTRA_OECMAKE_CATKIN = "\
-DCMAKE_PREFIX_PATH='${STAGING_DIR_HOST}${ros_prefix};${STAGING_DIR_HOST}${prefix};${STAGING_DIR_NATIVE}${ros_prefix};${STAGING_DIR_NATIVE}${prefix}' \
...
...
This diff is collapsed.
Click to expand it.
recipes-ros/catkin/catkin-runtime_0.5.90.bb
0 → 100644
View file @
224b15a0
ROS_SPN = "catkin"
require catkin.inc
S = "${WORKDIR}/catkin-${PV}"
# This package includes ONLY the python packages.
# The catkin_${PV} package includes all other files
# from the catkin tool.
FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}"
RDEPENDS_${PN} = "\
python-catkin-pkg python-argparse python-misc python-multiprocessing \
python-shell python-subprocess python-xml python-pkgutil"
# Delete everything but the python packages in order to avoid
# that the QA error [installed-vs-shipped] hits on us.
do_install_append() {
rm -rf ${D}${ros_bindir}
rm -rf ${D}${ros_datadir}
rm -rf ${D}${ros_libdir}/pkgconfig
}
This diff is collapsed.
Click to expand it.
recipes-ros/catkin/catkin.inc
0 → 100644
View file @
224b15a0
DESCRIPTION
=
"Low-level build system macros and infrastructure for ROS"
SECTION
=
"devel"
LICENSE
=
"BSD"
LIC_FILES_CHKSUM
=
"file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS
=
"cmake python-empy python-catkin-pkg python-empy-native python-catkin-pkg-native"
SRC_URI
=
"https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI
[
md5sum
]
=
"a0dd74c4a665a56b02af9f8c873c451d"
SRC_URI
[
sha256sum
]
=
"71441206945e8d77dace831375effde5b5f54b95e3a054106848432eceec58c0"
SRC_URI
+=
"file://0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch"
inherit
catkin
FILES_
$
{
PN
}
-
dev
+=
"\
${ros_datadir}/eigen/cmake \
${ros_datadir}/ros/cmake \
${ros_datadir}/.catkin \
${ros_prefix}/.catkin \
${ros_prefix}/.rosinstall \
${ros_prefix}/_setup_util.py \
${ros_prefix}/env.sh \
${ros_prefix}/setup.* \
"
This diff is collapsed.
Click to expand it.
recipes-ros/catkin/catkin_0.5.90.bb
View file @
224b15a0
DESCRIPTION = "Low-level build system macros and infrastructure for ROS"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
require catkin.inc
DEPENDS = "cmake python-empy python-catkin-pkg python-empy-native python-catkin-pkg-native"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "a0dd74c4a665a56b02af9f8c873c451d"
SRC_URI[sha256sum] = "71441206945e8d77dace831375effde5b5f54b95e3a054106848432eceec58c0"
SRC_URI += "file://0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch"
inherit catkin
FILES_${PN}-dev += "\
${ros_datadir}/eigen/cmake \
${ros_datadir}/ros/cmake \
${ros_datadir}/.catkin \
${ros_prefix}/.catkin \
${ros_prefix}/.rosinstall \
${ros_prefix}/_setup_util.py \
${ros_prefix}/env.sh \
${ros_prefix}/setup.* \
"
DEPENDS_virtclass-native += "catkin-runtime"
RDEPENDS_${PN}_class-native = ""
RDEPENDS_${PN} = "cmake make binutils binutils-symlinks gcc gcc-symlinks g++ g++-symlinks \
python-catkin-pkg python-argparse python-misc python-multiprocessing \
python-shell python-subprocess python-xml python-pkgutil"
catkin-runtime"
# The files in ${PYTHON_SITEPACKAGES_DIR} are installed by
# the catkin-runtime package. Therefore, we remove them here
# so that they are not installed.
# Moreover: the ${ros_libdir}/python2.7 is empty. We need to
# remove it, otherwise the QA error [installed-vs-shipped] will hit on us.
do_install_append() {
rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}
rmdir ${D}${ros_libdir}/python2.7
}
BBCLASSEXTEND += "native"
This diff is collapsed.
Click to expand it.
recipes-ros/catkin/
catkin
/0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch
→
recipes-ros/catkin/
files
/0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch
View file @
224b15a0
File moved
This diff is collapsed.
Click to expand it.
recipes-ros/ros-comm/roslaunch_1.10.12.bb
View file @
224b15a0
...
...
@@ -16,7 +16,6 @@ SRC_URI += "file://0001-increase-rosmaster-timeout.patch \
ROS_PKG_SUBDIR = "tools"
RDEPENDS_${PN} = "\
coreutils \
python-textutils \
python-logging \
python-threading \
...
...
This diff is collapsed.
Click to expand it.
recipes-ros/ros/rosclean/0001-rosclean-Use-du-sk-1024-on-Linux-for-getting-disk-us.patch
0 → 100644
View file @
224b15a0
From 300ac79a86f580040a1676004e1e8758cc7c6781 Mon Sep 17 00:00:00 2001
From: Alexis Ballier <aballier@gentoo.org>
Date: Thu, 22 Jan 2015 09:56:41 +0100
Subject: [PATCH] rosclean: Use "du -sk * 1024" on Linux for getting disk usage
since "du -b" is not supported by busybox du, while "du -k" is supported by
both coreutils and busybox.
Upstream-Status: Submitted [https://github.com/ros/ros/pull/76]
---
tools/rosclean/src/rosclean/__init__.py | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tools/rosclean/src/rosclean/__init__.py b/tools/rosclean/src/rosclean/__init__.py
index 5dafb05..6f051f1 100644
--- a/tools/rosclean/src/rosclean/__init__.py
+++ b/tools/rosclean/src/rosclean/__init__.py
@@ -121,13 +121,13 @@
def get_disk_usage(d):
"""
Get disk usage in bytes for directory
:param d: directory path, ``str``
- :returns: disk usage in bytes (du -b) or (du -A) * 1024, ``int``
+ :returns: disk usage in bytes (du -k) * 1024 or (du -A) * 1024, ``int``
:raises: :exc:`CleanupException` If get_disk_usage() cannot be used on this platform
"""
# only implemented on Linux and FreeBSD for now. Should work on OS X but need to verify first (du is not identical)
if platform.system() == 'Linux':
try:
- return int(subprocess.Popen(['du', '-sb', d], stdout=subprocess.PIPE).communicate()[0].split()[0])
+ return int(subprocess.Popen(['du', '-sk', d], stdout=subprocess.PIPE).communicate()[0].split()[0]) * 1024
except:
raise CleanupException("rosclean is not supported on this platform")
elif platform.system() == 'FreeBSD':
--
1.9.3
This diff is collapsed.
Click to expand it.
recipes-ros/ros/rosclean_1.10.11.bb
View file @
224b15a0
...
...
@@ -6,3 +6,5 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc
require ros.inc
ROS_PKG_SUBDIR = "tools"
SRC_URI += "file://0001-rosclean-Use-du-sk-1024-on-Linux-for-getting-disk-us.patch;striplevel=3"
This diff is collapsed.
Click to expand it.
recipes-ros/ros/roslib_1.10.11.bb
View file @
224b15a0
...
...
@@ -9,4 +9,4 @@ require ros.inc
ROS_PKG_SUBDIR = "core"
RDEPENDS_${PN} = "python-rospkg catkin"
RDEPENDS_${PN} = "python-rospkg catkin
-runtime
"
This diff is collapsed.
Click to expand it.
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
.
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment
Menu
Projects
Groups
Snippets
Help